package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bhas\b\W*`)
var str = `user hashimoto has two dogs`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}