using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"eot\?[^'""]+";
string substitution = @"eot";
string input = @"@font-face {
src: url('../some-font.eot?v=4.6.3');
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}