import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "eot\\?[^'\"]+";
final String string = "@font-face { \n"
+ " src: url('../some-font.eot?v=4.6.3');\n"
+ "}";
final String subst = "eot";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}