$re = '/^(.*)[<]+(?\'start\'.*)[>]+(.*)[<]+[\/]+(\k\'start\')[>]+(.*)$|^(.*)[<]+(.*)|[\/]+[>]+(.*)$/';
$str = 'https://009099mbaf.papersave.com:448/PaperSave.WebModule/logon.aspx?ReturnUrl=/PaperSave.WebModule/DocumentExplorer.aspx?ParentID="><img src=aaa onerror=alert(10484773)>&TransactionType=Contract&Module=Contract+Administration&HostApplication=Dynamics+GP&Company=Fabrikam,+Inc.&Action=CopyLink&ParentID="><img src=aaa onerror=alert(10484773)>&TransactionType=Contract&Module=Contract+Administration&HostApplication=Dynamics+GP&Company=Fabrikam,+Inc.&Action=CopyLink#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);