$re = '/(?<=[\w ]{5})\w+/m';
$str = 'I am a phrase and everything is matched after 10 characters.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);