using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s*href=""([^""]*)""[^>]*>(.*)<\/a>";
string input = @"<a href=""http://www.kimoco.it/prodotti/mazzette/"" title=""Mazzette colori""><img src=""http://www.kimoco.it/wp-content/uploads/2013/06/ico-mazzette-colori.png"" alt=""mazzetta colori"" width=""125"" height=""92"" /></a>
<a href="" title=""Mazzette colori"">CIAO</a>
<a href=""mailto:<U+2028>info@kimoco.it""><U+2028>info@kimoco.it</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}