package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a\s*href="([^"]*)"[^>]*>(.*)<\/a>`)
var str = `<a href="http://www.kimoco.it/prodotti/mazzette/" title="Mazzette colori"><img src="http://www.kimoco.it/wp-content/uploads/2013/06/ico-mazzette-colori.png" alt="mazzetta colori" width="125" height="92" /></a>
<a href="" title="Mazzette colori">CIAO</a>
<a href="mailto:<U+2028>info@kimoco.it"><U+2028>info@kimoco.it</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}