use strict;
my $str = '<a href="http://www.kimoco.it/prodotti/mazzette/" title="Mazzette colori"><img src="http://www.kimoco.it/wp-content/uploads/2013/06/ico-mazzette-colori.png" alt="mazzetta colori" width="125" height="92" /></a>
<a href="" title="Mazzette colori">CIAO</a>
<a href="mailto:<U+2028>info@kimoco.it"><U+2028>info@kimoco.it</a>';
my $regex = qr/<a\s*href="([^"]*)"[^>]*>(.*)<\/a>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}