# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/('click \.buttonaudio': function\(evt\) {
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound)\.src = \$\(evt\.currentTarget\)\.attr\('data-audiosrc'\);)
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound\.play\(\);
},)/\1\n\t\taddSpinner(\2,$(evt.currentTarget);\n\t\t\3/g;t' <<< "'click .buttonaudio': function(evt) {
$.k2l.m2a24_6.sound.src = $(evt.currentTarget).attr('data-audiosrc');
$.k2l.m2a24_6.sound.play();
},"