using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('click \.buttonaudio': function\(evt\) {
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound)\.src = \$\(evt\.currentTarget\)\.attr\('data-audiosrc'\);)
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound\.play\(\);
},)";
string substitution = @"\1\n\t\taddSpinner(\2,$(evt.currentTarget);\n\t\t\3";
string input = @"'click .buttonaudio': function(evt) {
$.k2l.m2a24_6.sound.src = $(evt.currentTarget).attr('data-audiosrc');
$.k2l.m2a24_6.sound.play();
},";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}