# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"('click \.buttonaudio': function\(evt\) {\n"
r" (\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound)\.src = \$\(evt\.currentTarget\)\.attr\('data-audiosrc'\);)\n"
r" (\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound\.play\(\);\n"
r" },)")
test_str = ("'click .buttonaudio': function(evt) {\n"
" $.k2l.m2a24_6.sound.src = $(evt.currentTarget).attr('data-audiosrc');\n"
" $.k2l.m2a24_6.sound.play();\n"
" },")
subst = "\\1\\n\\t\\taddSpinner(\\2,$(evt.currentTarget);\\n\\t\\t\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.