re = /(?:\G(?!\A)|^(?!.*\.join\.))(.*?)PD_/m
str = 'it.mycompany.db.beans.str1.PD_T_PD_CLASS
it.mycompany.db.beans.join.PD_T_CLASS
it.mycompany.db.beans.str2.PD_T_CLASS_1
it.mycompany.db.beans.join.PD_T_CLASS_1
PD_T_CLASS myVar = new PD_T_CLASS();
myVar.setPD_T_CLASS(something);'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result