package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<Button[^>]*[\n\s]+className[^>]*>`)
var str = `<Button className={style.red} />
<Button className={style.red}> </Button>
<Button
palette="primary"
className={style.blue}
/>
<Button
palette="primary"
/>
<Button
palette="primary"
className={style.blue}
>
</Button>
<Button
palette="primary"
condition={ value => 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette="primary"
condition={ value <= 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette="primary"
className={style.blue}
condition={ value => 5 ? props1 : props2 }
/>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}