const regex = /\. #([^\\.]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\. #([^\\\\.]*)$', 'gm')
const str = `#abc #def This is a test paragraph. #ads I only want to remove the hashtags after the full stop at the end and keep the hashtag at the center. These hashtags should be removed. #ads #ime #abc`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);