Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?:\sfrom\s+(?<from>[^\s*]+)[\s]*(?:(?:[\[\(.]?(?<fromh>.*?)?\.?\ *?[\[\(]?(?<fromip>(?:[0-9a-z]*?[\.\:]+[0-9a-z]*?)+)?[\)\]]+)?)(?=[\s;]+(?:by|with|via|id|for|;)\s*?)|\s+by\s+(?<byv>.*?)(?:\s+?\((?:[a-z\-\.]*?\s+)*?\[?(?<byip>(?:(?:[0-9a-z]*?[\.\:]+[0-9a-z]*?)+))*\]?\)?)?(?=[\s;]+(?:from|with|via|id|for|;)\s*?)|\s+via\s+(?<via>[a-z0-9\.\s]*?)(?=(?:\s*;|[\s]+(?:from|by|with|for|id|;))\s*?)|\swith\s+(?<protocol>(?:.|\s)*?)(?=(?:\s*;|[\s]+(?:from|by|via|for|id|;))\s*?)|\s+id\s+(?<id>[^\s;]+)(?=(?:\s*;|[\s]+(?:from|by|via|with|for|;))\s*?)|\s+for\s+<?(?<for>[^\s;>]+)>?(?=(?:\s*;|[\s]+(?:from|by|via|with|id|;))\s*?)|;\s+(?<date>[a-z]{3},\s+[0-9]{1,2}\s+[a-z]{3,4}\s+[0-9]{4}\s+[0-9]{2}\:[0-9]{2}\:[0-9]{2}\s+(?:-[0-9]{4}\s+)?(?:\([a-z]+\)|\+[0-9]{4}))?\n?)
/
gmi
Input 1
1
New
Received: from VE1PR01MB5599.eurprd01.prod.exchangelabs.com (aze [2603:10a6:7:7c::43]) by HE1PR0102MB2714.eurprd01.prod.exchangelabs.com with HTTPS via HE1PR0402CA0054.EURPRD04.PROD.OUTLOOK.COM with toto; Thu, 9 Jan 2020 16:34:13 +0000 Received: from relay-in.ohc.cu (relay-in.ohc.cu [127.0.0.1]) by relay-out.ohc.cu (Postfix) with ESMTP id 69EA722DD for <some.email@some.domain>; Thu, 9 Jan 2020 11:29:43 -0500 (CST) Received: from correo.patrimonio.ohc.cu (unknown [192.168.229.20]) by relay-out.ohc.cu (Postfix) via hello with ESMTP id B83BA22F5 for <some.email@some.domain>; Thu, 9 Jan 2020 11:29:36 -0500 (CST) Received: from correoweb.patrimonio.ohc.cu (unknown [192.168.229.23]) by correo.patrimonio.ohc.cu (Postfix) with ESMTPA id EC62A232A00A; Thu, 9 Jan 2020 11:39:53 -0500 (CST) Received: from VE1PR01MB5599.eurprd01.prod.exchangelabs.com (2603:10a6:7:7c::43) by HE1PR0102MB2714.eurprd01.prod.exchangelabs.com with HTTPS via HE1PR0402CA0054.EURPRD04.PROD.OUTLOOK.COM; Thu, 9 Jan 2020 16:34:13 +0000 Received: from VI1PR0102CA0029.eurprd01.prod.exchangelabs.com (2603:10a6:802::42) by VE1PR01MB5599.eurprd01.prod.exchangelabs.com (2603:10a6:803:11f::30) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.2602.12; Thu, 9 Jan 2020 16:34:13 +0000 Received: from DB5EUR01FT034.eop-EUR01.prod.protection.outlook.com (2a01:111:f400:7e02::203) by VI1PR0102CA0029.outlook.office365.com (2603:10a6:802::42) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.2623.9 via Frontend Transport; Thu, 9 Jan 2020 16:34:13 +0000 Received: from relay-out.ohc.cu (200.55.138.44) by DB5EUR01FT034.mail.protection.outlook.com (10.152.4.246) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.2623.9 via Frontend Transport; Thu, 9 Jan 2020 16:34:12 +0000 Received: from relay-in.ohc.cu (relay-in.ohc.cu [127.0.0.1]) by relay-out.ohc.cu (Postfix) with ESMTP id 69EA722DD for <some.email@some.domain>; Thu, 9 Jan 2020 11:29:43 -0500 (CST) Received: from relay-out.ohc.cu ([127.0.0.1]) by relay-in.ohc.cu (relay-in.ohc.cu [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 7CZku5Y59vGC for <some.email@some.domain>; Thu, 9 Jan 2020 11:29:38 -0500 (CST) Received: from correo.patrimonio.ohc.cu (unknown [192.168.229.20]) by relay-out.ohc.cu (Postfix) with ESMTP id B83BA22F5 for <some.email@some.domain>; Thu, 9 Jan 2020 11:29:36 -0500 (CST) Received: from localhost (localhost.localdomain [127.0.0.1]) by correo.patrimonio.ohc.cu (Postfix) with ESMTP id 65413232A001 for <some.email@some.domain>; Thu, 9 Jan 2020 11:40:05 -0500 (CST) Received: from correo.patrimonio.ohc.cu ([127.0.0.1]) by localhost (correo.patrimonio.ohc.cu [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id hNMp-6lHHtzH for <some.email@some.domain>; Thu, 9 Jan 2020 11:40:05 -0500 (CST) Received: from correoweb.patrimonio.ohc.cu (unknown [192.168.229.23]) by correo.patrimonio.ohc.cu (Postfix) with ESMTPA id EC62A232A00A; Thu, 9 Jan 2020 11:39:53 -0500 (CST)