$re = '/(^\S+ )([^\n]*\n)\1([^\n]*\n)/sm';
$str = 'ABC-123 BLA bla</br>
ABC-123 lala lala</br>
ABC-234 AAA</br>
ABC-234 BBB</br></br>
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;