using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a(.*?)href=('|\"")([^\>]*).(jpe?g|png|gif|mp4|webp|bmp)('|\"")(.*?)>";
string input = @"<a href=""https://localhost/test"" target=""_blank"">TEST</a>
<a href=""http://localhost/test.jpg"" data-fancybox=""fancybox"" data-caption="">
<img src=""https://localhost/test-400x400.jpg"" alt="">
</a>
<a href=""https://localhost/te.2er44.-.awd.wd.ddwadst.jpg"">
<img src=""https://localhost/test-400x400.jpg"" alt="">
</a>
<a href=""https://localhost/test.svg"">
<img src=""https://localhost/test-400x400.jpg"" alt="">
</a>
<a href=""https://localhost/test.gif"">
<img src=""https://localhost/test-400x400.jpg"" alt="">
</a>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}