# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a(.*?)href=('|\")([^\>]*).(jpe?g|png|gif|mp4|webp|bmp)('|\")(.*?)>"
test_str = ("<a href=\"https://localhost/test\" target=\"_blank\">TEST</a>\n\n"
"<a href=\"http://localhost/test.jpg\" data-fancybox=\"fancybox\" data-caption=\"\">\n"
" <img src=\"https://localhost/test-400x400.jpg\" alt=\"\">\n"
"</a>\n\n"
"<a href=\"https://localhost/te.2er44.-.awd.wd.ddwadst.jpg\">\n"
" <img src=\"https://localhost/test-400x400.jpg\" alt=\"\">\n"
"</a>\n\n"
"<a href=\"https://localhost/test.svg\">\n"
" <img src=\"https://localhost/test-400x400.jpg\" alt=\"\">\n"
"</a>\n\n"
"<a href=\"https://localhost/test.gif\">\n"
" <img src=\"https://localhost/test-400x400.jpg\" alt=\"\">\n"
"</a>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.