re = /^(#\d+ )?(\w+) ([^|]+)/m
str = '#12 1320 Water Street|Kelowna, British Columbia V1Y9P4
1320 Water Street|Kelowna, British Columbia V1Y9P4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end