// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(#\d+ )?(\w+) ([^|]+)").unwrap();
let string = "#12 1320 Water Street|Kelowna, British Columbia V1Y9P4
1320 Water Street|Kelowna, British Columbia V1Y9P4
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}