#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=X-Filename:[a-zA-Z\s0-9.*+-_/]*\n\n)([^\n\r]*)"
Local $sString = "X-Filename:WW CXVFVDFV324234." & @CRLF & _
"" & @CRLF & _
"dfweadfeafwerfwerfgwer"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")