using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=X-Filename:[a-zA-Z\s0-9.*+-_/]*\n\n)([^\n\r]*)";
string input = @"X-Filename:WW CXVFVDFV324234.
dfweadfeafwerfwerfgwer";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}