$re = '/(?<=X-Filename:[a-zA-Z\s0-9.*+-_/]*\n\n)([^\n\r]*)/m';
$str = 'X-Filename:WW CXVFVDFV324234.
dfweadfeafwerfwerfgwer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);