re = /(?<=X-Filename:[a-zA-Z\s0-9.*+-_\/]*\n\n)([^\n\r]*)/m
str = 'X-Filename:WW CXVFVDFV324234.
dfweadfeafwerfwerfgwer'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end