using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"jform\[([\w\-]+)\]\[?([\w\-]+)?\]?";
string input = @"jform[eqF-Weqwe][csdf_332]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}