re = /Two and (?<=and )Person/m
str = 'By Person One, Person Two and Person Three'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end