Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
"
^[1-9]\d*(?[\,\.]\d{3})?$
"
gm
Input 1
1
New
3434.34534..45435.3454 2323.23 10.34 10.. 2123.23.232 23432432 23432frerw33243 00076785.75675 fsf3454dfgdfg fdgd43545.34543 435435.435.345 1000000 1.77676767676 145435.534545 34.43 3545.34545 4324324324.324324324324dgdg 324342 2343.2343 32224323.