$re = '/(?<=Invoice number: |Invoice Number: |Invoice no: |InvoiceNumber: )\d{6}/m';
$str = 'Invoice number: 123456
Invoice Number: 123456
Invoice no: 123456
InvoiceNumber: 123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);