package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(o(?1)?o)`)
var str = `
o
oo
ooo
oooo
ooooo
oooooo
ooooooo 7
oooooooo 8
ooooooooo 9
oooooooooo 10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}