re = /(o(?1)?o)/
str = '
o
oo
ooo
oooo
ooooo
oooooo
ooooooo 7
oooooooo 8
ooooooooo 9
oooooooooo 10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end