re = /test_function\('[^'\\]*(?:\\.[^'\\]*)*'\s*,(true|false)/
str = 'test_function(\'something\',true);
//or
test_function(\'something\',false);
//or
test_function(\'something\',true,true);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end