#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b([A-z*]+)-(?=[A-z*]+\b)"
Local $sString = "Jean-Pierre bought "blue-green-red" product-2345 and other blue-red stuff."
Local $sSubst = "$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)