// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<MC>mc16[acde])\.(?P<SHORTNAME>.+?)\.(?P<MXAODFLAVOUR>MxAOD.+?)\.(e[0-9]+_s[0-9]+_r[0-9]+)?_?(?P<PTAG>p[0-9]+)(?:\.(?P<HTAG>h[0-9]+(?:-\w+?)?))?(?:(?:\.|_)(?P<N>[0-9]+))?\.root").unwrap();
let string = "mc16a.MGPy8_tHjb125_yt_plus1.MxAODDetailed.e4606_s3126_r9364_p3665.root
mc16a.PowhegPy8_NNPDF30_VBFH125.MxAODDetailed.e5720_s3126_r9364_p3665.root
mc16a.PowhegPy8_NNLOPS_ggH125.MxAODDetailed.e5607_s3126_r9364_p3665.root
mc16a.PowhegPy8_NNLOPS_ggH125.MxAODDetailed.e5607_s3126_r9364_p3665.h024.root
mc16d.PowhegH7_NNLOPS_ggH125.MxAODDetailed.p3524.h021-pid.root
mc16a.MGPy8_ttgamma_nonallhadronic_AF2.MxAODDetailed.p3469.h019.root
mc16a.PowhegPy8_NNPDF30_VBFH125.MxAODLeptonMETSys.p3404.h019.004.root";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}