package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).* ([0-9]|[1-9][0-9]{1,4}|1[0-9]{5}|2[0-2][0-9]{4}|230000) [12]0 X.*`)
var str = `-z001 230001 20 X
-z011 26321 10 *
-z002 230000 10 X
-z003 134242 12 *
-z004 199999 10 X
-z005 299999 20 X`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}