import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".* ([0-9]|[1-9][0-9]{1,4}|1[0-9]{5}|2[0-2][0-9]{4}|230000) [12]0 X.*";
final String string = "-z001 230001 20 X\n"
+ "-z011 26321 10 *\n"
+ "-z002 230000 10 X\n"
+ "-z003 134242 12 *\n"
+ "-z004 199999 10 X\n"
+ "-z005 299999 20 X";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}