# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B\*\b([^*]*(?:\b\*\b[^*]*)*)\b\*\B/<em>\1<\/em>/gx;t' <<< "The well known *H*rry P*tter*."