use strict;
my $str = 'The well known *H*rry P*tter*.';
my $regex = qr/\B\*\b([^*]*(?:\b\*\b[^*]*)*)\b\*\B/xp;
my $subst = '<em>\\1</em>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";