import Foundation
let pattern = #"\B\*\b([^*]*(?:\b\*\b[^*]*)*)\b\*\B"#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"The well known *H*rry P*tter*."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<em>\1</em>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)