re = /^(?:[^\/]+\/){4}\K(?:[^_]+_){3}[^_]+/
str = 'path/to/the/file/text_I_want_tokeep_loremipsumdolorsitamet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end