package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)GeSHi\s*([\w]+)`)
var str = `GeSHi hiii
GeSHi test
GeSHi elepjhant
GeSHi var1
GeSHi fun97
GeSHi abstarct
GeSHi String`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}