#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^dev_[0-9]+(?:.[0-9]+)+$"
Local $sString = "dev_1.0" & @CRLF & _
"dev_1.1" & @CRLF & _
"dev_1.2" & @CRLF & _
"dev_1.2.3" & @CRLF & _
"dev_1.2.3.4" & @CRLF & _
"dev1.2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")