import re
regex = re.compile(r"^dev_[0-9]+(?:.[0-9]+)+$", flags=re.MULTILINE)
test_str = ("dev_1.0\n"
"dev_1.1\n"
"dev_1.2\n"
"dev_1.2.3\n"
"dev_1.2.3.4\n"
"dev1.2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")