// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\((.*)\)").unwrap();
let string = "<li><a href=\"/wiki/%C3%81_Bao_A_Qu\" title=\"Á Bao A Qu\">Á Bao A Qu</a> (<a class=\"mw-redirect\" href=\"/wiki/Malay_(ethnic_group)\" title=\"Malay (ethnic group)\">Malay</a>) – Entity that lives in the <a href=\"/wiki/Vijaya_Stambha\" title=\"Vijaya Stambha\">Tower of Victory in Chitor.</a></li>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}