const regex = /(?<=volume.*?href=\").*?(?=\")/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=volume.*?href=\\").*?(?=\\")', 'ig')
const str = `<br>volume 1 <a href="https://www.google.com" /a><br>
<br>image <a href="https://www.facebook.com" /a><br>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}