re = /(?<=volume.*?href=\").*?(?=\")/i
str = '<br>volume 1 <a href="https://www.google.com" /a><br>
<br>image <a href="https://www.facebook.com" /a><br>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end