re = /(?:\G(?!\A)|\[(?=[^][]*]))[^]"]*\K"([^]"]*)"|"[^"]*"(*SKIP)(*F)/m
str = 'abc "[" def "ghi" ijk "]" lmn ["opq", "rst"] uvw or abc ["def", "g]hi"] jkl'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result