import Foundation
let pattern = #"(?:\G(?!\A)|\[(?=[^][]*]))[^]"]*\K"([^]"]*)"|"[^"]*"(*SKIP)(*F)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"abc "[" def "ghi" ijk "]" lmn ["opq", "rst"] uvw or abc ["def", "g]hi"] jkl"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)