import Foundation
let pattern = #"@(\S+) (\S+) (\S+(?: -> \S+)*) ?((?:(?!\*\/).)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/**
* Class Object
* @package Model\Example\Objects
* @property-read int id
* @property order_id
* @property string|NULL external_order_id -> externalOrderId
* @property string order_source
* @property int order_source_id
* @property string order_source_info foo, foo, bar.
* @property int order_status_id
* @property int date_add
* @property int date_confirmed
* @property int date_in_status
* @property string user_login
* @property string phone
* @property string email
* @property array products 21 foobar*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)