use strict;
my $str = 'Link Europe/London Yup
Link America/London Golden
Link Asia/London GB-EFire
Link Croatia/London GB-EFire
';
my $regex = qr/^Link[\s]*([a-zA-Z\/\-]*)[\s]*([a-zA-Z\/\-]*)$/mp;
my $subst = '\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";