Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^((?!\.)[\w-_.]*[^.])(@\w+)(\.\w+(\.\w+)?[^.\W])$
/
gm
Input 1
1
New
lama.loca.loca123@inca.com pio_pio@factory.com carnival666@hellmail.com la-lalai@gmail.com //INVALID EMAILS //spaces at start testmail@mail.com //start with points .testmail@mail.com //finish with points testmail@mail.com. //spaces into the string testm ail@mail.com //Start/finish with any not number|letter char testmail@mail.com.de testmail@mail.de.org